Aller au contenu
Logo Caradisiac        

Téléchargez nos application

Disponible sur App Store Disponible sur Google play
Publi info

Alfano du pauvre à fabriquer soi-même


Invité §qui132Xn

Messages recommandés

P....n c'est beau!

On voit le passionné qui maîtrise son sujet!

Toutes mes félicitations pour cet admirable travail.

J'ai deux petites questions:

sur la vidéo, tu testes la prise de Vi sur un ventilo et si j'ai bien compris il faudra mettre ce capteur proche d'une roue sur laquelle on aura fixé un aimant. J'ai bon??? Comment le système gère cette vitesse sachant qu'en fonction de la position de l'aimant (plus ou moins excentré) la vitesse n'est pas la même (ça tourne + vite à l’extérieur)

La deuxième question porte sur la taille des sondes de T°. J'ai vu qu'elles étaient fixées sur des mini circuits imprimés. comment les intégrer dans les supports de prise de T° que l'on trouve actuellement? J'ai l'impression que ces mini circuits imprimés sont larges...

Enfin, l'intégration générale. C'est vrai que mettre ce super boulot dans un boitier "fait maison", ça risque de gâcher, surtout qu'il y a pas mal de chose à intégrer (bouton M/A, 3 boutons poussoirs, emplacement SD, pile, etc...).

Quelles sont les dimensions de l'ensemble?

tiens nous au courant de la suite.

Lien à poster
Partager sur d’autres sites
  • Réponses 424
  • Créé
  • Dernière réponse

Participants fréquents à ce sujet

Participants fréquents à ce sujet

Invité §qui132Xn

héhé merci :)

Alors pour répondre à tes questions dans l'ordre.

 

Ouip, il faudra fixer un aimant sur la roue, peu importe son endroit le capteur compte le nombre de tours de roue, qu'il soit près du moyeu ou près du pneu tu auras toujours le même nombre de tours ;)

Près du moyeu sera je pense mieux pour 2 raisons :

- La première est que ça aura un impact moindre sur l'équilibrage (j'ai plus mes quelques cours de méca :D )

- La 2ème est qu'il passera moins vite devant le capteur

 

Les sondes sont effectivement peut être un poil large, 10mm sur la partie la plus large. Après montage on peut limer pour arriver à 7mm je pense ...

 

Pour les dimensions, ça donne approximativement (lxLxh) : 116x54x25mm

Lien à poster
Partager sur d’autres sites

héhé merci :)

Alors pour répondre à tes questions dans l'ordre.

 

Ouip, il faudra fixer un aimant sur la roue, peu importe son endroit le capteur compte le nombre de tours de roue, qu'il soit près du moyeu ou près du pneu tu auras toujours le même nombre de tours ;)

Près du moyeu sera je pense mieux pour 2 raisons :

- La première est que ça aura un impact moindre sur l'équilibrage (j'ai plus mes quelques cours de méca :D )

- La 2ème est qu'il passera moins vite devant le capteur

 

Les sondes sont effectivement peut être un poil large, 10mm sur la partie la plus large. Après montage on peut limer pour arriver à 7mm je pense ...

 

Pour les dimensions, ça donne approximativement (lxLxh) : 116x54x25mm

 

 

 

OK

J'avais bien compris le système, mais j'avoue que j'avais fait une petite confusion avec un vieux reste de cours d'aéro et de vitesse en bout de pale d'helice...whistle.gif

Par contre si le capteur compte le nombre de tours (qui est le même quelque soit la position de l'aimant ;) ), je suppose qu'il faut introduire dans la programmation une notion de dimension de roue (qui ne fait pas le même nombre de tours,en fonction de son diamètre,pour une Vi donnée ;);) ) et donc ce paramètre est différent en fonction si tu places le capteur face à la roue avant ou à la roue arrière (je parle dans le cas d'un kart...)

 

En ce qui concerne la sonde de T°, le capteur de T° sur le mini circuit doit il être en contact pour mesurer la T°?

Je pose cette question pour savoir s'il n'y aura pas de problème sur la résistance à la T° du mini circuit. Je me doute que le capteur en lui même ne posera pas de problème, il est prévu pour ça, mais en sera t il de même pour le support du capteur (le mini circuit et ses composants) :??:

 

Enfin, dans les dimensions que tu donnes, est ce que le logement de la pile est prévu?

 

merci encore de tout le temps que tu passes sur ce projetjap.gif

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Effectivement, il y a une variable que l'on peut paramétrer pour définir le diamètre de la roue, dans le menu "config", "wheel dia". On la voit très très rapidement dans la vidéo ;)

 

Concernant les sondes de T°, elles sont capables de mesurer jusqu'à 125°C.

Le circuit imprimé résiste lui jusqu'à 140°. Bon après honnêtement je ne l'ai pas testé jusqu'à ces températures.

 

Les dimensions sont sans la pile, je compte personnellement le relier directement sur la batterie ... que vous ne devez pas avoir sur vos kart j'imagine non.gif.1a95bc97eb5081a797a1220950cc42fa.gif

 

La partie capteur RPM sur le fil de la bougie ne marche pas actuellement, je suis en train de voir avec l'aide de Bobbylebob pourquoi.

Lien à poster
Partager sur d’autres sites

Tu te trompesnon.gif

de plus en plus de kart dispose de batterie,tous les TaG (Touch and Go) avecdémarreurintégré

Ce sont en général des 12V

Comment ton système gère la tension, car si je ne me trompe, la pile utilisée sur la vidéo est une 9V... :??:

 

par contre, autant le relier à la batterie serait intéressant car nos batteries (pour ceux qui en ont :D ) se rechargent en roulant, mais cela ferait un fil de plus qui se baladederrièrele volant, et ça c'est moins cool car entre la sonde de T°, le capteur de Vi , le capteur pour le chrono et le futur capteur rpm, ça fait beaucouppt1cable.gif

 

A moins qu'il soit possible de faire sortir du picfano un seul cable (avec plusieurs fils) vers une espèce de hub, plus loin et un peu plus discret, qui redistriburait les différents fils vers les différents capteurs :??:

 

Apresfaut voir s'il n'y aurait pas trop d'interférences entre les différents signaux (je suis pas électronicien, tu as du t'enapercevoirlol.gif)

Lien à poster
Partager sur d’autres sites

Tu te trompesnon.gif

de plus en plus de kart dispose de batterie,tous les TaG (Touch and Go) avecdémarreurintégré

Ce sont en général des 12V

Comment ton système gère la tension, car si je ne me trompe, la pile utilisée sur la vidéo est une 9V... :??:

 

par contre, autant le relier à la batterie serait intéressant car nos batteries (pour ceux qui en ont :D ) se rechargent en roulant, mais cela ferait un fil de plus qui se baladederrièrele volant, et ça c'est moins cool car entre la sonde de T°, le capteur de Vi , le capteur pour le chrono et le futur capteur rpm, ça fait beaucouppt1cable.gif

 

A moins qu'il soit possible de faire sortir du picfano un seul cable (avec plusieurs fils) vers une espèce de hub, plus loin et un peu plus discret, qui redistriburait les différents fils vers les différents capteurs :??:

 

Apresfaut voir s'il n'y aurait pas trop d'interférences entre les différents signaux (je suis pas électronicien, tu as du t'enapercevoirlol.gif)

Pardon pour ce qui va suivre..Mais je ne peux m'empêcher d'en remettre une couche.

Ce que tu avances est partiellement faux.. Les rotax ( et dieux..ou diable savent qu'ils sont nombreux)ne sont pas équipés d'un système de recharge..

Bon ça c'est fait.

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Tant mieux pour vous si je me trompe :)

Toute la partie à droite du LCD (vue de dessus) s'occupe de réguler la tension à 3.3v (la tension d'entrée doit être comprise entre 4,75v et 16v)

 

Pour toute la partie câblage, chacun fait comme il le souhaite.

J'ai proposé ma solution mais elle peut ne pas convenir à certains en fonction de l'intégration désirée donc faites comme bon vous semble !

 

Un seul câble avec plusieurs fils pourquoi pas, juste séparer peut-être du reste :

- Le fil enroulé autour de la bougie pour le capteur RPM (enfin si j'arrive à le faire marcher un jour)

- L'alimentation +12v

Lien à poster
Partager sur d’autres sites

Pardon pour ce qui va suivre..Mais je ne peux m'empêcher d'en remettre une couche.

Ce que tu avances est partiellement faux.. Les rotax ( et dieux..ou diable savent qu'ils sont nombreux)ne sont pas équipés d'un système de recharge..

Bon ça c'est fait.

 

 

pas de pb, un forum, c'est fait pouréchanger.

 

pourtant il me semble avoir entendu que les derniers rotax avait un système de recharge..

Mais n'en ayant jamais possédé (toujours du iame) je ne pourrai certifier, je laisse ça aux "rotaxmen"

Lien à poster
Partager sur d’autres sites

 

pas de pb, un forum, c'est fait pouréchanger.

 

pourtant il me semble avoir entendu que les derniers rotax avait un système de recharge..

Mais n'en ayant jamais possédé (toujours du iame) je ne pourrai certifier, je laisse ça aux "rotaxmen"

 

 

pourtant il me semble avoir entendu . tu a du mal entendre!!!!!!!!! non!!!!!! pas de systéme de recharge.

 

niko0710.gif.06a6d21d155966dc1493c2bb4804a46c.gif

Lien à poster
Partager sur d’autres sites
Invité §cro402Jx

bravo quicheddod, tu as integré les composant a ton PCB rapidement. tu etais impatient? ca tombe bien nous aussi :)

 

Tu voulais faire une liste de ce qu'il te reste a faire sur ce projet. Il te reste quoi a faire dans ta liste?

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

C'est le genre de projet qu'on ne termine jamais et que l'on veut toujours améliorer mais pour ça il faut du temps !

 

Pour cette version 0.2, reste à faire :

- Régler le problème du capteur RPM (Bobbylebob m'a filé un gros coup de main sur ce point ce we, faut que j'avance de mon coté)

- Tester le tout en conditions réelles

- Quelques modifications logicielles éventuellement mais ça c'est du détail ;)

Lien à poster
Partager sur d’autres sites
Invité §ste511VG

Salut à tous,

 

félicitation pour ta réalisation, on sent une maitrise incontestable de l'ingénierie.

Je fait de électronique aussi (en amateur) et je bricole pas mal mes motos.

Si je peux aider a faire avancer ce projet ce serait avec plaisir.

Je n'ai pas vue de schéma électrique sur le forum mais je suppose que c'est volontaire.

Pour l'interface capteur de RPM quel type de montage as tu utilisé?

Lien à poster
Partager sur d’autres sites
Invité §cro402Jx

- Tester le tout en conditions réelles

 

c'est la que ca se corse je crois. Le choix de sensibilité a niveau de la sonde ILS est assez delicat a faire d'apres ce que j'en sais. Tu vas pouvoir placer ta sonde a quelle hauteur par rapport a la piste?

Lien à poster
Partager sur d’autres sites
Invité §hkt552AF

 

pourtant il me semble avoir entendu . tu a du mal entendre!!!!!!!!! non!!!!!! pas de systéme de recharge.

 

niko0710.gif.063fcd3f2201345c708578a1064af358.gif

 

 

tout à fait, pas de recharge sur le max. Et comme il faut avoir une batterie toujours chargée à bloc (conditionne l'allumage) alors il vaut mieux ne rien brancher dessus autre que si qui est déjà prévu. Pour le x30 c'est différent, la batterie ne participe pas à l'allumage, une fois démarré on pourrait tourner sans.

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Salut à tous,

 

félicitation pour ta réalisation, on sent une maitrise incontestable de l'ingénierie.

Je fait de électronique aussi (en amateur) et je bricole pas mal mes motos.

Si je peux aider a faire avancer ce projet ce serait avec plaisir.

Je n'ai pas vue de schéma électrique sur le forum mais je suppose que c'est volontaire.

Pour l'interface capteur de RPM quel type de montage as tu utilisé?

 

Hello,

 

"maitrise incontestable" c'est peut-être beaucoup mais forte motivation pour faire aboutir un bricolage maison ça c'est sûr :)

 

Pour les curieux, voici le schéma du montage : Schéma v0.2

Pour ceux qui font un peu d'électronique n'hésitez pas à y jeter un oeil, il y sûrement des points à améliorer ...

 

Le capteur RPM est issu d'un Alfano (cf page 2).

A ce propos, le montage proposé par Bobbylebob fonctionne finalement très bien ... suffit de le tester correctement ange.gif.cdde55b4ffa665e2dbfdccc88e8e335e.gif. Reste à le tester sur un moteur 2 temps voir si mon montage va supporter tous ces parasites.

 

- Tester le tout en conditions réelles

 

c'est la que ca se corse je crois. Le choix de sensibilité a niveau de la sonde ILS est assez delicat a faire d'apres ce que j'en sais. Tu vas pouvoir placer ta sonde a quelle hauteur par rapport a la piste?

Ouaip, j'ai pris les ILS les plus sensibles, sur les karts ça ne devrait pas poser de problème vu la hauteur, sur les motos/voitures à voir.

Me concernant faut que je bricole un support qui permette de descendre le capteur assez bas. Je pensais le mettre dans le prolongement de la fourche avant ... faut juste vérifier que ça touche pas quand on tourne :D

Lien à poster
Partager sur d’autres sites
Invité §ste511VG

Salut,

 

j'ai trouvé cet exemple de "captage" qui me parait électroniquement intéressant:

http://www.sportdevices.com/rpm_readings/index.htm

Évidemment ça suppose un "pickup" genre pince ampèremetrique.

Le conditionnement du signal reste intéressant.

Les plus grosses perturbations électromagnétiques émises par les allumages proviennent souvent de l'absence de résistance

dans ce qui devient un capuchon de bougie à la place d'un "antiparasite".

Lien à poster
Partager sur d’autres sites
Invité §ste511VG

En regardant le schéma elec, je vois que les inter n'ont pas de condensateur anti rebond (mais j'ai vu une fonction debounce en lisant rapidement ton code je ne sait pas si c'était pour ça). Les pull up sur le port RB sont pratiques mais ajouter le condo reste d'expérience une bonne solution.

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

ça va devenir le refuge des électroniciens ici :D

J'ai fait quelques tests ce soir sur ma pocket bike avec le montage équivalent à celui de l'Alfano. Le problème est le suivant, je capte beaucoup trop de changements de fronts.

 

Après simulation du montage par Bobbylebob on s'est rendu compte que le montage génère une impulsion à chaque changement de front en entrée, donc en gros je dois diviser mon résultat par 2.

Là mon compteur s'incrémente d'environ 800/secondes !! (moteur 2T au ralenti je précise)

 

A priori le montage fonctionne bien chez Bobbylebob qui l'avait testé il y a quelques temps, il y a quelque chose qui ne va pas sur mon montage ... plus qu'à trouver la cause.

 

On trouve effectivement d'autres types de montages sur le net, pas pu tous les tester et j'aimerai bien que l'actuel fonctionne chez moi cry.gif.7fe335eb95a4ccfc22acdf07a33e8d55.gif

Pour le debounce, yep il est géré de manière logicielle, sur les boutons ça fonctionne à priori bien jusqu'à présent.

Lien à poster
Partager sur d’autres sites
Invité §ste511VG

Sur ton schéma elec je ne vois pas de découplage a proximité de ton trigger 74AHC1G1?

ça peut peut être améliorer ton signal de sortie une petite capa de 100nF en céramique

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Salut,

 

j'ai trouvé cet exemple de "captage" qui me parait électroniquement intéressant:

http://www.sportdevices.com/rpm_readings/index.htm

Évidemment ça suppose un "pickup" genre pince ampèremetrique.

Le conditionnement du signal reste intéressant.

Les plus grosses perturbations électromagnétiques émises par les allumages proviennent souvent de l'absence de résistance

dans ce qui devient un capuchon de bougie à la place d'un "antiparasite".

 

 

Intéressant ! Je ne connaissais pas ! La partie filtrage qu'ils utilisent est intéressante. Sur le premier schéma, ils précisent que le couplage capacitif entre le fil qui va à la bougie et le condo de 22pF est fait à travers le PCB, entre les couches top et bottom. Dans notre cas avec quichedood, on utilise un second fil en parallèle de celui qui va à la bougie pour faire le couplage capacitif.

 

Lui utilise une pull-down de 100k et un condo de 22pf. Je pense que tu peux essayer de remplacer la 2.2Mohms par une 100k et éventuellement d'ajouter cette capa de 22pf.

Les beaux jours reviennent, dès que mon déménagement est terminé je pique un scope au boulot et j'essaie de mettre au point ce bout de schéma, si Alfano y arrive, nous aussi !

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Résultats de la journée.

 

La partie du montage "Alfano" avec un LMC555 avant d'arriver sur le µproc et l'ajout du C de 22pF : ça améliore un peu les choses et évite à mon LCD de partir complètement vrille. mais j'ai toujours des valeurs pourries (pour le ralenti de 3000 à environ 20000rpm !!)

Le fait de supprimer les 2 diodes Schottky (BAT54S) ne change pas grand chose.

Passer la R de 2,2M à 100k améliore peut être un peu la précision (je teste avec un signal généré à partir d'un ventilo avec 2 aimants dessus et un ILS :D )

 

Bon après je teste aussi sur le 2T d'une pocket-bike "made in China", ça n'aide peut-être pas non plus ... m'enfin après tout si le moteur tourne c'est que le signal est là !

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Bon j'ai peut-être une idée ... après 6h de tests kaola.gif

 

Sur ma pocket-bike-à-pas-cher j'avais mis à l'époque une bougie NGK B7HS, or cette bougie là n'a à priori pas de résistance interne.

Quand je vois la tête de mon antiparasite, je me dis que lui non plus ne doit pas avoir de résistance intégrée !

 

D'après vous ça vaut le coût que je teste avec une bougie équipée d'une R interne ? (bon c'est pas vraiment pour le prix que ça coûte ...)

Ou je change l'antiparasite ...

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

C'était ça !!!

Bougie remplacée par modèle équivalent avec résistance intégrée et hoooo magie plus aucun parasite !

 

Reste plus qu'un petit détail à régler c'est que le nombre de tour/min captés varie beaucoup en fonction de la longueur des 2 fils accolés entre eux (ex : 1cm de fil en commun : 900rpm, 10cm de fil en commun : 5000rpm).

 

on avance, on avance !

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Cool, de bonnes nouvelles sur la mise au point de cet étage de mesure ! Je suis un peu déçu, je pensais que l'ajout du monostable serait une solution miracle prête à être intégrée définitivement, mais c'est déjà une très bonne avancée.

 

Si je comprends bien, tu as gardé l'étage amplificateur "Alfano original" et tu y as ajouté le LMC555 entre le buffer et le micro ?

 

La prochaine étape serait de remplacer complètement l'étage "Alfano Original" par celui là : http://www.sportdevices.com/rpm_readings/SP1%20ignition%20sense.gif.

 

Il me parait plus simple, et éventuellement moins efficace en terme d'amplification (et donc peut être moins sensible aux parasites).

 

En tout cas, j'avais le même genre de comportement que toi concernant la longueur du couplage et la variation de la mesure...

 

Je pense que les Alfano intègrent une petite ferrite de couplage entre le fil de mesure et le circuit de mesure... Mais je pense qu'on n'a pas besoin de creuser dans cette direction pour le moment vu que d'autres y arrivent sans ça...

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Si je comprends bien, tu as gardé l'étage amplificateur "Alfano original" et tu y as ajouté le LMC555 entre le buffer et le micro ?

 

 

Ouaip

 

La prochaine étape serait de remplacer complètement l'étage "Alfano Original" par celui là : http://www.sportdevices.com/rpm_readings/SP1%20ignition%20sense.gif.

 

 

Je l'avais testé samedi, avant de change ma bougie (forcément ça marchait pas mieux). A retester.

 

Je pense que les Alfano intègrent une petite ferrite de couplage entre le fil de mesure et le circuit de mesure... Mais je pense qu'on n'a pas besoin de creuser dans cette direction pour le moment vu que d'autres y arrivent sans ça...

 

 

J'ai pensé à la ferrite en parcourant le web la semaine dernière mais je voyais pas trop comment l'intégrer, ça serait quand même pas mal d'avoir qu'un seul fil et pas 2 qu'on scotche au milieu :D

Bon à voir, je teste déjà l'autre montage pour voir ce que ça donne

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Oublie pas que sur le schéma ci-dessus, le couplage entre les deux fils est fait par deux pistes PCB, l'une en face top, l'autre en bottom, ce qui permet de n'avoir qu'un fil soudé vers la bougie, soudé directement sur le PCB.

Ce week-end j'essaie de piquer un oscilloscope au boulot pour voir ce qu'il en est !

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Autorisation de piquer un scope pour ce week end accordée par le chef. Va maintenant falloir planifier les mesures entre les couches de bébé, les promenades en famille et l'emménagement des cartons...

 

Au fait quichedood, toi aussi t'es connecté en permanence sur le forum pendant les heures de boulot ? :D

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Le premier lien est effectivement un bon retour d'expérience, il contredit totalement ce que nous faisons tous, à savoir mettre le fil de mesure en parallèle du fil de bougie... Quichedood, on attend ton retour pour voir si ça peut améliorer les choses !

 

Le second lien ne me parait pas très clair, j'ai l'impression que la mesure du régime est prise directement sur l'allumage, et non pas par couplage, donc je ne suis pas sur qu'on puisse appliquer ce schéma à notre besoin (sauf quichedood sur son ER-6, mais c'est de la triche ! :-D)

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×
  • Créer...