Aller au contenu
Logo Caradisiac        

Téléchargez nos application

Disponible sur App Store Disponible sur Google play
Publi info

Alfano du pauvre à fabriquer soi-même


Invité §qui132Xn

Messages recommandés

  • Réponses 424
  • Créé
  • Dernière réponse

Participants fréquents à ce sujet

Participants fréquents à ce sujet

Invité §qui132Xn

Voilà voilà j'arrive !

 

Bon au final rien d'extraordinaire, je suis donc parti du schéma à base de NE555 ... sans le modifier :D

Pour faire un post un peu moins inutile j'apporte ma contribution de testeur-en-condition-réelle

 

Les résultats sont meilleurs lorsque le lien entre le montage et le moteur sont de la sorte :

(M)-------

------------NE555

Par contre, les 2 fils scotchés entre eux peuvent l'être sur 1cm ou sur 10 ça ne changera rien, le signal interprété est toujours le même.

 

A l'inverse dans ce cas (même fil soudé coté NE555 et enroulé autour du fil HT), les valeurs fluctuent beaucoup plus.

(M)-------------------NE555

 

Pour donner des chiffres :

Mesure sur un intervalle de temps de 500ms avec un moteur 2T au ralentie

Cas N°1 : la valeur oscille entre 20 et 21 impulsions

Cas N°2 : la valeur oscille entre 18 et 32 impulsions (pics à 35)

Et évidemment, avoir une bougie ou un antiparasite avec une résistance intégrée sinon aucune chance !

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Tiens, ça me fait penser à une astuce de programmation... Comment convertis-tu ton comptage d'impulsions en tours/min ? Je te dirai comment je fais après... :-D

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Hmmm pour l'instant je faisais bêtement une multiplication par 120 (mesure sur 0,5sec).

Mais il faudra arrondir à la centaine la plus proche pour que ça fasse un peu plus propre.

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Héhé, si tu fais tes mesures sur 0,6sec, tu obtiens un joli coefficient multiplicateur de 100... Il te suffit ainsi d'afficher directement le nombre d'impulsions comptées avec deux '0' derrière et roule ma poule ! Même si les micros modernes savent très bien faire des multiplications, ça t'évite de devoir gérer une variable 16 bits pour ton régime, tu ne stockes qu'une variable 8 bits (limitée à 25600t/min, ce qui me semble suffisant)

 

Sinon, concernant tes résultats de mesure, je n'ai pas tout saisi. Au début tu disais que la longueur de couplage entre les fils jouait beaucoup sur la lecture et que même avec le montage du schéma "à base de BC547" ce n'était pas stable. Qu'est ce qui a changé entre les deux essais ? Juste la bougie avec résistance ? Comment as-tu placé le fil sur le câble HT ? Enroulé comme sur les liens de stephanovitch ou simplement fixé parallèle ?

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

héhé pas bête le coup des 0,6 sec mais dans mon cas ça va être compliqué (sans tout recommencer :p )

La longueur de couplage avec la "bonne" bougie fait beaucoup varier le résultat sur le schéma type Alfano, par contre sur celui à base de BC547 aucun problème.

 

ça doit être une histoire de sensibilité car avec le montage à base de BC547 en utilisant qu'un seul fil, j'ai +/- le même résultat (mesure assez variable).

 

Sinon tous mes tests ont été réalisés en enroulant de 3 tours le fil sur le câble HT.

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Intéressant !

Dans mon cas je compte le nombre d'impulsions sur une période de temps fixe (0,5 sec) et non l'inverse (calcul du temps entre 2 ou n impulsions).

Niveau interruption, j'en ai du coup qu'une seule toutes les demi-secondes peu importe le régime moteur.

 

Ce qui évite ça (même si ça peut se contourner évidemment) :

"Note! Because the measurement is done by period (for accuracy) the display updating time is based on machine speed. At very low RPMs the display will update every 2-3 seconds. At higher RPMs the display will update much faster, like a few times a second."

 

Bref va falloir optimiser tout ça niveau code pour avoir quelque chose de bien :)

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Perso, je fais comme quichedood, et je pense que c'est la façon la plus efficace au niveau charge CPU, mais elle a des inconvénients aussi.

Pour ma part, un compteur hardware s'incrémente à chaque impulsion, puis ce compteur est vidé toutes les 0.6secondes. il suffit d'afficher 2 "00" à la suite de la valeur pour avoir le régime.

La résolution est ainsi de 100t/min et l'affichage est rafraichi toutes les 0.6s.

Pour mon bargraph de led qui doit être plus réactif mais moins précis, je viens lire l'état de ce compteur toutes les 0.2s, la valeur est ensuite multipliée par 3 (décalage de bits). La résolution est ainsi de 300t/min mais rafraichie toutes les 0.2s.

Lien à poster
Partager sur d’autres sites
Invité §cro402Jx

Bonsoir,

Bravo, de beaux avancements.

Implementer un bar graph. C'est une bonne idée. Mais ca fait une information en plus a aller voir quand on roule. Ca fait pas trop a la fin?

On va finir par regarder plus longtemps les centrales de mesures plutot que la piste :)

 

en kart, beaucoup de pilote utilisent des kart avec boites de vitesses?

Je demance ca car un shift light est parfois plus efficace a lire pour le pilote.

 

Bonne continuation dans vos projets respectifs :)

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Je pense que le bargraph est pas mal, c'est très visuel ça permet en quelques millisecondes d'avoir un ordre d'idée de ton régime moteur.

J'avais hésité à l'implémenter mais ça fait pas mal de composants en plus, du coup je suis parti sur un "simple" shiftlight à 1 led.

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

C'est l'avantage du home made, on fait ce qu'on veut, et moi je trouvais que ça faisait classe le bargraph, même si ça me sert à rien avec mon rotax max ! :)

Lien à poster
Partager sur d’autres sites
Invité §ste511VG

Salut,

 

Quichedood, je viens de m'apercevoir que la ref d’écran Newhaven Display 4x20 en 3.3V n'est plus dispo chez Mouser hormis pour une quantité de 56 unités.

Je pense le commander chez DigiKey mais étant donnée les frais de port de 18€,si quelqu'un est intéressé, j'en commanderai bien 2 ou 3 d'un coup.

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

J'ai vu ça il y a quelques jours, le constructeur marquait la version en 3.0v comme une fin de série !!

En fait, elle est simplement remplacée par la version en 3.3v. sur Mouser c'est donc la nouvelle que tu vois mais ils ne l'ont pas encore en stock.

 

Réponse du commercial chez le constructeur :

Hello Edouard,

 

The NHD-0420H1Z-FSW-GBW-3V3 is being replaced by the NHD-0420H1Z-FSW-GBW-33V3. The new version requires a minimum supply voltage of 3.3V instead of 3.0V. All other characteristics such as the pinout, size, etc are still the same. So you can still use the same hardware connections, and software to drive the new display. You shouldn’t have to redesign your project.

 

The new version is still going through our approval process which is why you won't see it on our website. But samples should be available soon.

 

Let me know if you have any other questions.

S'il te manque que le lcd, je peux t'en revendre un (j'en avais commandé en plus pour ne pas payer les frais de ports sur Mouser :D ).

 

Pour le circuit imprimé tu le fais toi même ? J'ai des v0.2 si tu veux, je prépare la v0.3 avec un module RPM qui fonctionne à priori pas trop mal ;) (j'attends l'avis de Bobbylebob sur le design avant de le poster).

 

Pour les ILS il y celles-là : MK06-8-B

Ce n'est pas beaucoup plus cher et au moins ça ne se casse pas !

Lien à poster
Partager sur d’autres sites
Invité §ste511VG

Génial, je suis intéressé par un lcd et aussi par un circuit V0.2.

Sur la prochaine version tu ne vas changer que la plaquette acquisition régime, donc je la refabriquerais plus tard.

Je voulais passer la commande chez Mouser ce WE et je me suis raviser quand j'ai vue que l'écran etait indisponible.

Je te fais confiance pour l'ILS j'en commanderai un comme celui ci.

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Pour info, à corriger sur le circuit imprimé de la v0.2 :

- Quelques perçages à refaire plus gros

- 2 résistances de tirage à rajouter

Pour l'instant je n'ai pas trouvé d'autres erreurs.

 

Je peux te faire les modifs avant de te l'envoyer si tu veux.

Lien à poster
Partager sur d’autres sites
Invité §ste511VG

C'est sympa merci, pour les résistances je veux bien mais pour, les perçages j'ai ce qu'il faut. Si les pastilles sont métalisées je devrais ressouder des deux coté, mais comme le connecteur est a 90° si j'en crois les photos, je devrais y arriver sans problèmes.

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Cool, un deuxième bêta testeur, la couverture de test s'améliore ! :)

Désolé mon cher quichedood de ne pas avoir montré de signes de vie plus tôt, le week end j'ai à peine le temps d'aller sur le PC, et le proxy du boulot a été remis et il me bloque les MP sur le forum !

Peux-tu m'envoyer l'implantation de ton pcb par email à ardouin.david arobase gmail.com ? Je te ferai un retour dans la journée.

Lien à poster
Partager sur d’autres sites
Invité §cro402Jx

Pour la sonde ILS MK06-8-B que tu as mis en lien:

"Tension d'alimentation de fonctionnement: 175 V"

Sur un kart, ca va etre chaud a trouver du 175V :)

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Pour la sonde ILS MK06-8-B que tu as mis en lien:

"Tension d'alimentation de fonctionnement: 175 V"

Sur un kart, ca va etre chaud a trouver du 175V :)

 

Bien vu, mais t'en fais pas, il s'agit seulement de la tension maximale que peut couper l'ILS. C'est un composant complètement passif et mécanique qui n'a pas besoin d'alimentation, il a juste besoin d'un champ magnétique pour se fermer.

Lien à poster
Partager sur d’autres sites
Invité §cro402Jx

par curiosité, le fonctionnement de la sonde s'apparente plus un contacteur controler par le champ magnetique ou plutot comme un relais controler par le champ magnetique?

En gros, est ce qu'il y a qu'une boucle a fermer ou ouvrir ou il y a une partie commade et ue partie puissance dans la sonde ILS?

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

L'ILS c'est juste 2 lames métalliques qui rentrent en contact lorsqu'on le soumet à un champs magnétique.

On le voit très bien sur cette image : ILS

 

T'as bien reçu mon mail Bobbylebob au fait ?

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Ah non, je n'ai toujours pas reçu ton mail... Je viens de voir qu'il avait atterri dans ma boite Spam !

 

Cool, tu m'as mis tout le routage, je vais regarder ça. Plus de détails en MP, les règles de routage et la CEM ne sont pas forcément captivantes pour tout le monde, surtout sans avoir la carte sous les yeux !

Lien à poster
Partager sur d’autres sites
Invité §qui132Xn

Hop v0.3 : ici

[h4]Changelog v0.3 (qq petites corrections mineures + un module RPM qui fonctionne grâce à vous tous ;) )

[/h4]

  • Ajustement positionnement composants (connecteur JP1, potentiomètre CONTRAST, C1, C9, L1, 11DQ06, LM2574, LED, R11, R12, MMBT3904)
  • Correction taille perçages (L1, 11DQ06, connecteur Molex)
  • Ajout résistance R10 de tirage à la masse sur JP1
  • Ajout résistance R1 de tirage à la masse sur capteur RPM
  • Utilisation de CMS pour les 2 condensateurs au niveau du quartz
  • Refonte module capteur RPM
  • Réduction taille connecteur Molex (supression de 4 connecteurs pour sonde de T° supplémentaire, modification du circuit imprimé des sondes de T°, les 2 sondes se relient désormais en série)
  • Ajout circuit imprimé pour capteurs vitesse et tour
  • Utilisation de capteurs ILS différents (protégés, moins sensibles à la casse)

 

Je n'ai pas encore commandé le circuit imprimé pour cette version.

Si certains d'entre vous sont intéressés, dites le moi on fera une commande groupée ;)

Lien à poster
Partager sur d’autres sites
Invité §rus535xh

Bonjour à tous,

 

Après la lecture des 6 pages de ce topic je suis vraiment en admiration face à tout le travail que vous êtes en train de réaliser !

Aussi, je vois que le sujet de la sonde de température n'a avancé que très peu et donc je me permets d'essayer d'apporter les infos que j'ai pu trouver. Je m'explique: depuis quelques semaines je me suis fait voler ma sonde de température lors d'une course (posée sur l'établi entre midi et deux elle a subitement disparue :-( ) du coup je suis bien décidé à m'en fabriquer une et ne pas payer 90€ chez nos amis belges.

Voilà où j'en suis:

- alfano pro v1 donc connecteur TNC mâle et câcle RG 58

ça c'était pour le branchement côté alfano maintenant de l'autre côté:

- il me faut une résistance CTN de 47k plutôt résistante face aux vibrations (et là je ne sais laquelle utiliser)

- en plus de la résine epoxy dans laquelle je noierai la résistance, il me faut la mélanger à une résine qui permette un transfert de température optimum (pas envie d'attendre 1H avant de voir la température monter au compteur !!!) et enfin la mélanger à un loctite bi-composant pour que tout tienne dans le contenant.......ce qui amène donc à parler de ce fameux contenant.......et là je suis sec je ne sais lequel choisir !!!

 

Je résume donc, il me manque pour achever l'opération:

- référence de la CTN 47k

- référence résine epoxy

- référence résine transfert de chaleur

- référence loctite bi-composant

- le contenant de la résistance et de la résine

 

Je vais surement me faire assassiner que je n'ai finalement pas grand chose... :-(( mais justement je ne suis pas un expert et je suis un peu au bout de mes compétences. En espérant trouver un peu d'aide de votre côté...

 

Bonne journée à toutes et à tous en attendant de vous relire !

 

Sportivement

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Je me suis un peu penché sur la question d'un capteur de température adaptable.

Moi je voyais ça comme ça :

- Vis M10 au pas de 100, longueur de l'ordre de 20mm qui sera vissée dans la culasse à l'endroit habituel des sondes de T°C (voir : http://www.visseriefixations.f [...] e-100.html

- Cette vis serait percée au tour à métaux à un diamètre genre 4 - 5mm. Attention, perçage borgne sur une profondeur de 15mm.

- Dans le trou serait inséré la CTN (http://fr.farnell.com/te-conne [...] dp/2042923). J'ai choisi un modèle CMS 0805, petit à souder mais aussi plus réactif. L'ensemble CTN/fil est emballé dans un morceau de gaine thermorétractable de l'ordre de 10cm de long, voire même 2 épaisseurs superposées pour la résistance au pliage

- Collage de la CTN dans le trou à la colle époxy bi composant.

 

Même si l'epoxy ne conduit pas très bien la chaleur, le faible volume de la "sonde de température" que l'on vient de fabriquer devrait assez rapidement atteindre la température du moteur.

L'inconvénient des composants que je te propose, notamment la vis, c'est qu'il y a un mini de commande de 15€ chez visseriefixations.fr, et 12€ de port chez Farnell... A voir si on peut trouver la même chose ailleurs !

Lien à poster
Partager sur d’autres sites
Invité §rus535xh

Salut Bobby,

 

Tout d'abord merci pour ta réponse :-))

 

Concernant le trou borgne, je ne comprends pas pourquoi tu parles de trou borgne et ensuite de profondeur de 15mm... un trou borgne c'est un perçage de part en part non ? donc normalement on traverse totalement la pièce ? Du coup je comprends plus... lol

Moi je pensais plutôt percer sur 15mm à un diamètre de 4/5mm et les 5mm qui reste faire un trou de diamètre inférieur afin que la résine vienne en contact direct avec l'eau vu qu'à mon avis elle conduira toujours mieux qu'une vis en acier et du coup l'ensemble sera bien plus réactif.

Concernant la longueur de la vis, du 20mm sera amplement suffisant, un copain doit mesurer ce soir la longueur du filetage sur une sonde d'origine.

Qu'en penses tu de tout ça ?

 

Pour ce qui est de la quantité ce n'est pas grave car j'ai pas mal d'amis qui sont intéressés donc on se partagera les frais entre nous et au pire si des gens du forum sont intéressés et bien ils s'ajouteront à la liste :--))

 

La colle époxy bi-composant il faudrait vraiment quelqu'un qui s'y connaisse pour nous conseiller car il faut qu'elle résiste à la chaleur et aux vibrations.

 

Idem pour la CTN, penses tu que la référence que tu as choisie est suffisamment costaud ? Ou tu l'as prise plus ou moins au pif ?

 

Merci encore

Lien à poster
Partager sur d’autres sites
Invité §Bob078Yy

Il me semble qu'un trou borgne est justement un trou non débouchant, d'où les 15mm, mais peut être que je me trompe... Enfin bref, un trou qui ne débouche pas quoi !

Moi j'éviterais de percer la vis de part en part, c'est le moyen le plus sur concernant l'étanchéité. En plus, comme le métal est meilleur conducteur de chaleur que l'époxy, ce serait tout bénef.

 

J'ai fait pas mal de modélisme et la colle époxy est couramment utilisée. Pour la tenue aux vibrations y'a pas de souci, et la température de l'ordre de 80°C à cet endroit ne devrait pas poser de problème non plus.

Pour la CTN, je pensais d'abord à une version traversante ("sur pattes" ;) , mais finalement, une CMS me paraît plus adaptée. Le point faible dans une connexion est situé au niveau des soudures. Il vaut mieux que la partie soudée soit noyée dans la résine au plus profond de la vis. La CTN en elle-même ne craint rien.

 

Il faudrait déjà faire un premier essai pour valider le principe, voir si la vis se monte bien etc... mais je suis assez confiant !

Lien à poster
Partager sur d’autres sites
Invité §rus535xh

Non c'est moi qui me trompe après vérification... tu as la bonne définition du trou borgne ;-)

Es-tu sur qu'une vis en acier conduira mieux la chaleur que la résine ? Parce que la plupart des résines sont thermo-conductrices...et je ne suis pas certain que l'acier soit meilleur conducteur. Le temps de réaction de la sonde sera à mon avis trop long. De plus avec la résine ce sera étanche si c'est bien plein. Concernant la résine, tu prendrais quoi d'ailleurs ? T'as une référence ? Il en faudrait en "grosse" quantité du coup si on en fait plusieurs.

 

Ce n'est pas compliqué à souder une CMS ?

Je ne connais pas...car si ce n'est pas monté sur patte ça se soude comment ? Directement sur le composant ?

 

Pour ce qui est de la vis, si c'est effectivement du M10 x 100 y'a pas de raison qu'elle ne se monte pas.

 

C'est cool on avance :-))

Lien à poster
Partager sur d’autres sites
Invité §jej307Wn

Salut

Moi j'ai percer de part en part et coulé de la resine thermoconductrice acheté chez RS.

Me rapelle plus du prix mais pareil ; on a fait une tournée de 10 pcs donc pas cher.

Ca fait 2 ans et pas une fuite rien; et pas moins reactive que l'origine.

Voila juste mon petit retour d'experience

A+

 

Ref resine :

http://www.rs-particuliers.com/WebCatalog/Resine_Ep_Thermo_Cond-552668.aspx

 

(Pas tres cher mais connais pas les frais de port)

Lien à poster
Partager sur d’autres sites
Invité §rus535xh

Effectivement MICA ça va commencer à faire un peu cher je pense...

 

Jejep, quand tu parles d'une tournée de 10pcs tu veux dire que tu as fait 10 sondes avec une seule quantité achetée ou vous avez groupé vos achats avec des amis ? En gros quelle quantité de résine te faut il pour faire ta sonde ?

Avec quoi l'as-tu faites comme contenant ? Vis M10x100 percée ? Si oui, à combien l'as tu percée ?

 

Merci pour la ref de résine mais apparemment je suis pas prêt de l'avoir si je la prends chez RS (pas dispo avant Mai !!)

 

Super on avance ! Dès que j'aurai commencé à en réaliser je vous ferai bien entendu un retour :-))

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×
  • Créer...